Microsoft outage
Incident Report for Lockstep Receivables
Resolved
Mircrosoft has resolved their issues and Self-Service is fully operational.
Posted Apr 02, 2021 - 11:45 UTC
Investigating
Live self-service is currently down due to an issue with Microsoft.
See below to get status:
https://status.azure.com/en-us/status
Posted Apr 01, 2021 - 22:08 UTC
This incident affected: Lockstep Customer Portal Application.