March 2021 Release
Incident Report for Lockstep Receivables
Resolved
This has been completed
Posted Apr 01, 2021 - 11:47 UTC
Identified
Lockstep Collect will be undergoing maintenance later tonight in preparation of our upcoming publish. During this time, you may experience issues using the software's features. The maintenance is expected to take place after 8 PM EST. Anytime Collect is expected to be upgraded and fully operational before 12 AM EST tomorrow. We appreciate your understanding and hope you enjoy the new features added!
Posted Mar 31, 2021 - 21:23 UTC
This incident affected: Anytime Collect Web Application (my.anytimecollect.com - North Central US, au.anytimecollect.com - Australia East, eu.anytimecollect.com - West Europe).